Your browser does not allow this site to store cookies and other data. Some functionality on this site may not work without them. See Privacy Policy for details on how we would use cookies.

Tectia

System Requirements

Check the following table for the operating systems supported as Tectia Server platforms:

Table 2.1. Supported operating systems per Tectia product

Operating SystemClientConnectSecureServerServer for Linux z1Server for z/OS1
HP-UX (PA-RISC) 11i v1, 11i v2, 11i v3 11i v1, 11i v2, 11i v3 11i v1, 11i v2, 11i v3
HP-UX (IA-64) 11i v2, 11i v3 11i v2, 11i v3 11i v2, 11i v3
IBM AIX (POWER) 5.3, 6.1, 7.1 5.3, 6.12, 7.1 5.3, 6.1, 7.1
Oracle Solaris (SPARC) 9, 10 9, 10 9, 10
Oracle Solaris (x86-64) 10 10 10
Oracle Linux (x86-64)3 5, 6 5, 6 5, 6
Red Hat Enterprise Linux (x86 and x86-64) 4, 5, 6 4, 5, 6 4, 5, 6
SUSE LINUX Enterprise Desktop (x86 and x86-64) 10 10 10
SUSE LINUX Enterprise Server (x86) 9, 10, 11 9, 10, 11 9, 10, 11
SUSE LINUX Enterprise Server (x86-64) 10, 11 10, 11 10, 11
Microsoft Windows (x86) XP, Server 2003, Vista, Server 2008, 7 XP, Server 2003, Vista, Server 2008, 7 XP, Server 2003, Server 2008, 7
Microsoft Windows (x64) Server 2003, Vista, Server 2008, Server 2008 R2, 7 Server 2003, Vista, Server 2008, Server 2008 R2, 7 Server 2003, Server 2008, Server 2008 R2, 7
VMware ESX Server4 3.5 3.5
Red Hat Enterprise Linux for IBM System z (64-bit) 4 5.1, 6
SUSE LINUX Enterprise Server for IBM System z (64-bit) 5 9, 10
SUSE LINUX Enterprise Server for IBM System z (31-bit) 9
IBM z/OS (zSeries) 1.10, 1.11, 1.12

1 Including the client components.

2 Tectia ConnectSecure requires reconfiguring the RBAC mode on AIX 6.1 and later.

3 Oracle Linux with Unbreakable Enterprise Kernel is also supported.

4 Tectia products can be installed directly on the server virtualization layer.

5 Requires the 31-bit compatibility library libc.so.6.

[Note]Note

Keep the operating system fully patched according to recommendations by the operating system vendor.

The supported operating systems are required to have the following or superseding patches or maintenance levels installed. Tectia solutions have been tested with the following patches and maintenance levels:

  • IBM AIX 5L 5.3: Technology level 10 (fix to AIX bug IDs IZ50489 and IZ14988). Note that these fixes are also available as service packs for some earlier technology levels.

  • IBM AIX 6.1: Technology level 3 (fix to AIX bug IDs IZ46727 and IZ17492). Note that these fixes are also available as service packs for some earlier technology levels.

  • IBM AIX requires the following updated C++ runtime libraries:

    • Fileset update: bos.rte.libc 5.3.8.1

    • Fileset update: bos.rte.security 5.3.8.1

    • Base level update: xlC.rte 10.1.0.0

  • Microsoft Windows XP: Service Pack 2 and 3

  • Microsoft Windows Server 2003: Service Pack 2.

  • Microsoft Windows Server 2008: Service Pack 1.

  • Red Hat Enterprise Linux 4 and 5: xorg-x11-xauth is required for X11 forwarding

  • Sun Solaris 9:

    • The Solaris 9 Recommended Patch Cluster, Jun 5, 2006

    • 112908-30 krb5, gss Patch, May 30, 2007

    • 111711-25 32-bit Shared library patch for C++, Nov, 2009

    • 111712-25 64-bit Shared library patch for C++, Nov, 2009

  • SUSE Linux Enterprise Server 10: Service pack 1

  • SUSE Linux Enterprise Server 9 for IBM System z: Service pack 4

  • SUSE Linux Enterprise Server 10 for IBM System z: Service pack 1

HP-UX patches

The general principle is to install the latest HP-required patch bundle for the OS version, currently required bundles exist for 11i v1 and 11i v2. Proper functioning of the Tectia software also requires the latest HP recommended patches for libc, pthread and linker tools. In addition, some individual patches may be needed to fix specific problems. Such patches are mentioned separately.

[Note]Note

Check the HP web-site for any newer patches superseding the ones listed here. We recommend installing the latest version recommended by HP.

  • HP-UX 11i v1 on PA-RISC requires the following patches:

    • B.11.11.0306.1 patch bundle for HP-UX 11i v1, Jun 2003

    • PHKL_34738 signal cumulative patch, Sep 2006

    • PHKL_34173 select(2) delay, hang, Jan 2006

    • PHKL_28122 signals, threads enhancement, psets enablement, Feb 2003

    • PHNE_36576 cumulative STREAMS patch, Apr 2008

    • PHNE_38678 cumulative ARPA transport patch, Apr 2009

    Install also these (currently) latest HP-recommended patches for libc, pthread and ld(1) and linker tools:

    • PHCO_33282 pthread library cumulative patch, Oct 2006

    • PHCO_35743 libc cumulative patch, Jan 2007

    • PHSS_37516 ld(1) and linker tools cumulative patch, Dec 2007

    For X11 forwarding, install also the following patches on the server machine you want to forward X11:

    • PHSS_34102 XClients patch, Dec 2005

    • PHSS_35711 X/Motif Runtime Periodic patch, Dec 2006

  • HP-UX 11i v2 on PA-RISC and IA-64 (Itanium):

    • B.11.23.0409.3 patch bundle for HP-UX 11i v2, Sep 2004

    • PHCO_34191 libc cumulative patch, Mar 2003

    • PHCO_36323 pthread library cumulative patch, Aug 2007

    • PHSS_37492 linker + fdp cumulative patch, Dec 2007

    • Kerberos Client D.1.6.2, Dec 2007

    • PHNE_34788 cumulative STREAMS patch, May 2007

    • PHNE_37395 cumulative ARPA transport patch, Dec 2007

    For X11 forwarding, install also the following patches on the server machine you want to forward X11:

    • PHSS_34159 XClients patch, feb 2006

    • PHSS_35046 XMotif Runtime patch, Oct 2006

  • HP-UX 11i v3 on PA-RISC and IA-64 (Itanium):

    • PHCO_36551 pthread library cumulative patch, May 2007

    • PHSS_37202 linker and fdp cumulative patch, Oct 2007

    • Kerberos Client D.1.6.2, Dec 2007

When PAM Kerberos is used on HP-UX 11i v1, the following Kerberos-related patches are needed in addition to those mentioned above:

  • PHCO_34214, libpam_unix cumulative patch, July 2006

  • PHNE_25779, LDAP-UX Integration B.02.00 cumulative patch, March 2002

  • PHSS_33384, KRB5-Client Version 1.0 cumulative patch, June 2005

===AUTO_SCHEMA_MARKUP===